Posts Tagged ‘605’

And another thing…

March 22, 2009

Even though it’s wifi enabled, you have to pay $40 to buy the web browser piece for the Archos so that you can use it to surf the net.

In fact just about every add on costs extra. Save yourself the money and just go buy an iPod!

Advertisements

I’ve said it before…

March 21, 2009

And I’ll say it again.

DON’T buy an Archos.

We got a 605 wifi for my wife just before Christmas last year. It died before we’d even used it. Got it replaced under the extra warranty we took out (thankfully). New one just died after less than 3 hours use and all I’ve been doing it trying to record some video. Now I get error 102 and it looks like I’ve lost the video I had on it.

Piece of (French) crap.

Just calling it like it is.

Don’t…

February 7, 2009

archos-605

Buy an Archos video player. We bought one for my wife last year for when she is traveling. It’s not actually been used yet but I was trying to record some TV programs for her this weekend for an upcoming trip and the bloody thing died with what I can only call ‘the white screen of death’.
I managed to get it working after missing half an hour of the program I was trying to record and it lost pretty much everything on there, including wiping the saved videos from the SD card I had in there.

So it’s gone off to be repaired. Thankfully we bought an extended warranty for the thing so no questions asked but it’s a nuisance all the same and if it’s not reliable, what’s the point of it. Seems the error codes (101, 102) it throws is pretty common too.

It’s a shame because it’s a nice unit otherwise and the screen is much easier to see than an iPod Touch, but as I say, if it’s not reliable, what’s the point.

Bloody technology!